tulpanomicon/shell.nix

22 lines
471 B
Nix

let
pkgs = import <nixpkgs> { };
nur = import (builtins.fetchTarball
"https://github.com/nix-community/NUR/archive/master.tar.gz") {
inherit pkgs;
};
dyson = pkgs.callPackage ./nix/dyson.nix { };
tex = with pkgs;
texlive.combine { inherit (texlive) scheme-medium bitter titlesec; };
in pkgs.mkShell {
buildInputs = with pkgs; [
calibre
dyson
kubectl
kubectx
mdbook
nur.repos.mic92.pandoc-bin
tex
zathura
];
}